The SmartTools.CopyPaste extension adds the familiar copy and paste functionality to SharePoint Document Libraries. The SmartTools.CopyPaste extension can be installed by making use of wizard. After the activation of the Site Collection level feature, it can be used as follows:

First, navigate to a Document Library from which you want to copy a document. In the Edit Control Block (ECB) of a document, select Copy to Clipboard
CopyPaste1.jpg

A confirmation message will be displayed:
CopyPaste2.jpg

Navigate to the Document Library to which you want to paste the document, and select the Paste option from the Actions menu:
CopyPaste3.jpg

The result is that the file is copied!
CopyPaste4.jpg

Last edited Jun 14, 2008 at 9:53 AM by JanTielens, version 3

Comments

beak Jun 16, 2010 at 10:46 PM 
Hi - This looks like a great tool. Does this copy and post only work within document libraries? Will it work with lists?
Thank you.

thoqbk Jul 8, 2009 at 9:11 AM 
Hello,
first of all: Thanks for this great tool.
Nevertheless I was not able to copy a file into a folder (seems to be the same problem described by tuocle and derkrischi). Is there any solution to this?
Greetz.

Khanasif May 7, 2009 at 12:29 PM 
Thnak for these tools, i am abot new, can anyone please explain how can i install it. for example: SmartTools.CopyPaste. Many Thanks

tuocle Jan 26, 2009 at 5:48 PM 
Hello-
I was able to copy files from one documents library to another, however, I cannot copy files to a folder of the documents library. it always put the files at the top level. Can this be done?

Thanks.

JanTielens Jan 21, 2009 at 1:54 PM 
The "File Not Found" exception is solved in the next release (4.0)!

dtandukar Jan 16, 2009 at 8:22 AM 
great tool, but only the problem is it doesn't copy the history of the file and then no way you can update the copied document if the original is modified or changed. Any solution?

Deependra

gvraaij Dec 18, 2008 at 1:18 PM 
Hi people, I also HAD the same problem as Brian0184, kenthjansson131 and pfeilchris until I modified the 'SmartTools.CopyPaste.Copy.aspx' file.
I removed the following lines because they are not necessary for the aspx:

<%@ Register TagPrefix="wssuc" TagName="InputFormSection" Src="~/_controltemplates/InputFormSection.ascx" %>
<%@ Register TagPrefix="wssuc" TagName="InputFormControl" Src="~/_controltemplates/InputFormControl.ascx" %>
<%@ Register TagPrefix="wssuc" TagName="ButtonSection" Src="~/_controltemplates/ButtonSection.ascx" %>
<%@ Register TagPrefix="wssawc" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<%@ Register TagPrefix="SPSWC" Namespace="Microsoft.SharePoint.Portal.WebControls" Assembly="Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>

The file is located in the Sharepoint folder: c:\program files\common files\microsoft shared\web server extensions\12\TEMPLATE\LAYOUTS

Tip: after modifying the file, reset your IIS.

Happy Sharepoint!

Greetz Geert

pfeilchris Nov 10, 2008 at 9:55 AM 
Hello, I have the same problem as Brian0184 and kenthjansson131.
Is there any solution around ? Environment WSS 3.0 and .net Framework all versions..
Error is: File Not Found. at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) .......
Thanks Chris

artfulldodgers Sep 22, 2008 at 10:38 PM 
Hi, looks like a great web part and exactly what i want. However, cant get it to work and getting the same "file not found" error as both Brian 0184 and Kenthjansson.
Could you give some more detailed troubleshooting tips, i.e. exactly what files are expected and where.

Thanks in advance

kenthjansson131 Sep 18, 2008 at 9:15 PM 
Hi,
I have experienced the same problem as Brian0184 - I've installed it on a wss 3.0 environment.

MelodieBoyko Sep 2, 2008 at 4:44 PM 
I have found a million ways to copy and paste from one document library to another, can anyone tell me how to copy and paste from a SharePoint Doc Library to a Vista desktop?

derkrischi Aug 21, 2008 at 9:22 AM 
well done function :-) but i've two problems - first one: the icons on the actionmenu are not displayed (????) and the second one: the paste will be made everytime in the rootdirectory and not in the folder where i am (????). any ideas?

Brian0184 Aug 12, 2008 at 8:04 PM 
After installing Copy and Paste Tool I tried to test it out. When selecting the option to "Copy to Clipboard" I get error "File Not Found". I've tried bring in new documents into the library, and trying this feature out, but no luck. Any ideas?