Autocomplete - ASP.NET AJAX

Apr 12, 2009 at 5:49 PM
Hello.

From the below statement

This component uses the .NET Framework version 3.5 and ASP.NET AJAX. Make sure .NET 3.5 is installed on your server and ASP.NET AJAX has been configured before you install this component.

I cannot find any information on how to ensure ASP.NET AJAX has been configured.

Please can someone let me know how to do this.

Thanks.
May 6, 2009 at 4:50 AM
You need to install the .NET 3.5 framework with SP1.

Then you need to enable the AJAX funtionality in Sharepoint by modifying your web.config as described here;

http://weblogs.asp.net/jan/archive/2008/10/10/enabling-net-3-5-in-sharepoint-2007-sites-the-lazy-way.aspx

You then need to register the MIME types for AJAX in IIS as described here (3rd post);

http://smarttools.codeplex.com/Thread/View.aspx?ThreadId=47051

You're done!
Jun 10, 2009 at 12:10 PM

I'm trying from few days using AutoComplete TextField. I don't know what is wrong.

I have installed .Net framework 3.5 SP1, ASP AJAX Extensions, I configured web.config file as described above, but it's not working. When i try insert some text into AutoCompleteTextField field 'Connect to ....[my_server_name]' window appears asking for User name and Password. but even when I put some correct data (administrator user name and password) this windows pops up again and again.

Please help becouse I want to use this tool.